升级10.11后Xcode的CocoaPods插件报错

释放双眼,带上耳机,听听看~!

错误信息如图所示

CocoaPods

问题已解决,下面有解决方法,遇到相同问题的同学可以看看.

另外补充,10.11 cocoapods安装命令:

 sudo gem install -n /usr/local/bin cocoa pods

通过以上命令安装的cocoapods,那么在Xcode的cocoapods插件的GEM_PATH里写入 /usr/local/bin 即可

终端里:$ gem env

gem env

找到SHELL PATH:

    /usr/local/bin
/usr/bin
/bin
/usr/sbin
/sbin

gem path

修改Xcode的cocoapods插件里GEM_PATH:选项为上面得到的某一路径!
重新关闭打开Xcode over

如果上面方案仍没有解决问题,那么将GEM_PATH里写入 /usr/local/bin 执行cocoapods安装命令:

sudo gem install -n /usr/local/bin cocoa pods

over!


PS:

另附查看安装清单命令,可查看已安装应用及插件:

命令 :gem list 

 

人已赞赏
iOS文章

iOS UIButton基本属性及定义

2020-5-14 20:46:56

iOS文章

iOS UIWebView加载网页、文件、 html

2020-5-14 22:01:48

个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
有新消息 消息中心
搜索