CocoaPods的安装和使用

释放双眼,带上耳机,听听看~!

1.安装

1、环境配置
$ gem sources --remove https://rubygems.org/
//等有反应之后再敲入以下命令
$ gem sources -a http://ruby.taobao.org/
//查看是否成功
$ gem sources -l
2、安装cocoaPods
$ sudo gem install cocoapods

2、使用

pod init  //生成Podfile文件,在文件里面写
//pod 'SVProgressHUD'
//pod 'AFNetworking', '~> 2.5.4'
pod install   //生成的文件放在了Podfile所在的目录.
pod update   // 更新
pod search  //查找某个类库
//更新使用以下命令可以提升速度
pod install --verbose --no-repo-update
pod update --verbose --no-repo-update

3.Podfile
3.1. pod ‘objection’’version’;
例如,pod ‘MCDateExtensions’,不指定版本,在pod update时会获取最新的版本;pod ‘MCDateExtensions’’~>1.0.0’,获取的版本信息是[1.0.0, 1.1.0). ~>是参照ruby的语法的,~>x.y.z, 的意思是版本号 x,y 固定,但可以大于等于 z。通常版本号的命名有其惯例:x major 版本号升级表示有 API 发生不向后的兼容性变动,y minor 版本号升级表示有功能新增,z tiny 版本号升级表示 bugs 修正。因此 “~> x.y.z” 可以让我們保有升级弹性,又不致于升級太多让程序发生不兼容错误;

3.2. 从本地pod files, pod 'AFNetworking', :path => '~/Documents/AFNetworking''此目录下一定要有.podspec文档

3.3. 从git server端pod files

To use the master branch of the repo:
pod 'AFNetworking', :git => 'https://github.com/gowalla/AFNetworking.git', :branch => ‘develop’
Or specify a commit:
pod 'AFNetworking', :git => 'https://github.com/gowalla/AFNetworking.git', :commit => '082f8319af'

人已赞赏
iOS文章

iOS NSFetchedResultsController查询结果控制器

2020-2-20 22:44:32

iOS文章

iOS 自定义键盘

2020-2-21 3:15:48

个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索