Android开发appbuildintermediatesresmergeddebugvalues-v23values-v23.xml 编译出错的问题

释放双眼,带上耳机,听听看~!

接手了一个项目 ,需要二次开发,第一次运行的时候改了几个bug然后修改了一些配置然后就悲剧了。

 

 

然后一顿改appbuildintermediatesresmergeddebugvalues-v23values-v23.xml 

提示这个错误了 ,这个错误是更改gradle的时候引起的,你的gradle不匹配

apply plugin: 'com.android.application'
apply plugin: 'com.neenbedankt.android-apt'
android {
compileSdkVersion 23//之前是25 buildToolsVersion "23.0.1"defaultConfig {
applicationId "com.jier.scan"
minSdkVersion 14
 targetSdkVersion 23versionCode 1
versionName "1.0"
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
}
}
dependencies {
apt 'com.github.Raizlabs.DBFlow:dbflow-processor:4.0.0-beta2'
compile 'com.github.Raizlabs.DBFlow:dbflow-core:4.0.0-beta2'
compile 'com.github.Raizlabs.DBFlow:dbflow:4.0.0-beta2'compile 'com.androidadvance:topsnackbar:1.1.1'
compile 'com.google.android.gms:play-services-appindexing:8.4.0'
}

 

好了 解决了

 

人已赞赏
Android文章

Android java.lang.IllegalStateException: commit already called

2020-3-24 15:11:38

Android文章

Android数据库安全解决方案,使用SQLCipher进行加解密

2020-3-24 16:24:52

个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
有新消息 消息中心
搜索