Android开发React Native version mismatch 错误处理

释放双眼,带上耳机,听听看~!

错误描述:

console.error: React Native version mismatch.

JavaScript version:0.57.8

Native version:0.55.4

引发原因:

在运行项目之前,我本地node服务中已经运行了另外一个RN项目,而另外那个项目的js版本为0.55.4,要运行的项目js版本为0.57.8。所以就引发了上面的错误。解决办法就是关闭node服务,重新运行项目就可以了(react-native run-android 命令启动项目时,如果node服务没有启动,会自动启动)。

node服务中不能同时运行不同js版本的项目

人已赞赏
Android文章

Android通知工具类,含8.0通知适配,打开通知设置页面适配

2020-3-10 2:54:33

Android文章

Android开发react navigation 依赖添加

2020-3-10 4:54:29

个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
有新消息 消息中心
搜索