[!] You need at least git version 1.8.5 to use CocoaPods (Pod::Informative)

释放双眼,带上耳机,听听看~!

安装cocoapods报错:

HOLOTHURIAN:~ sharktop$ pod setup

/Library/Ruby/Gems/2.3.0/gems/cocoapods-1.4.0/lib/cocoapods/command.rb:129:in `verify_minimum_git_version!': [!] You need at least git version 1.8.5 to use CocoaPods (Pod::Informative)
from /Library/Ruby/Gems/2.3.0/gems/cocoapods-1.4.0/lib/cocoapods/command.rb:49:in `run'
from /Library/Ruby/Gems/2.3.0/gems/cocoapods-1.4.0/bin/pod:55:in `<top (required)>'
from /usr/local/bin/pod:23:in `load'
from /usr/local/bin/pod:23:in `<main>'   

 

1、有一种可能是cocoapods安装成功了,但是链接Xcode的版本过低,所以需要更新Xcode。

2、或者你电脑安装了多个版本的Xcode,就需要修改链接Xcode路径,改成链接电脑比较高版本的Xcode。

3、本人单纯的就是重装了Xcode出现了该报错,使用了如下命令。

修改链接命令如下(后面的路径根据你较高版本Xcode路径修改)

sudo xcode-select -switch /Applications/Xcode.app/Contents/Developer

人已赞赏
iOS文章

IOS -查询我们使用的静态库和动态库支持的平台(例如arvm7)

2020-3-2 9:33:22

iOS文章

iOS webView和WKWebView 返回历史页面

2020-3-2 10:22:20

个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
有新消息 消息中心
搜索