使用cocoapods时常见错误

释放双眼,带上耳机,听听看~!

这些错误基本cocoapods升级版本到1.0.0之后的版本所造成的

 

错误1、

当写在Podfile文件中的第三方框架,不能使用,找不到时

查看Pods文件夹,是否下载了所需要的第三方框架,没有的话就 pod update

 

错误2、

Could not automatically select an Xcode project. Specify one in your Podfile like so:xcodeproj ‘path/to/Project.xcodeproj’

在Podfile文件里指定下工程目录就行了

xcodeproj ‘Demo/Demo.xcodeproj’

 

但是如果cocoapods版本为(1.0.0或更高)的话,可能会有以下警告

[!] xcodeproj was renamed to `project`. Please use that from now on.

这时只需要把xcodeproj改为 project就行了

project ‘Demo/Demo.project’

 

错误3、

The dependency `AFNetworking (~> 3.0)` is not used in any concrete target.

在Podfile中添加

target‘项目名’do  (如  target ‘Demo’ do )

 

错误4、

[!] Invalid `Podfile` file: syntax error, unexpected end-of-input, expecting keyword_end.

在Podfile的末尾添加 end

 

错误5、

Unable to find the Xcode project `/Volumes/BIAO/iOS/code/MBWB.xcodeproj` for the target `Pods`.

在Podfile中 将  project ‘Demo/Demo.project’  改成  project ‘Demo.project’

错误6、

build diff: /../Podfile.lock: No such file or directory

在工程设置中的Build Phases下删除Check Pods Manifest.lock及Copy Pods Resources

 

2018

错误7、 RuntimeError – [Xcodeproj] Unknown object version.

[Xcodeproj] Unknown object version. /Applications/CocoaPods.app/Contents/Res…

原因: Xcode 版本和 CocoaPods 的版本不匹配,需要更新 CocoaPods

解决方法:终端输入命令 $ gem install cocoapods –pre

 

还有一个更新慢的问题:无论是执行pod install还是pod update都卡在了Analyzing dependencies不动

原因在于当执行以上两个命令的时候会升级CocoaPods的spec仓库,加一个参数可以省略这一步,然后速度就会提升不少。加参数的命令如下:

pod install –verbose –no-repo-update

pod update –verbose –no-repo-update

补充:cocoapods也有了自己的客户端,可

人已赞赏
iOS文章

Xcode真机测试 您需要安装JDK才能使用java命令工具

2020-1-16 11:25:21

iOS文章

iOS开发UITableView 下拉刷新和上拉加载

2020-1-16 13:25:34

个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
有新消息 消息中心
搜索